mIRC Home    About    Download    Register    News    Help

Print Thread
cutting & pasting Japanese text often doesn't work #214022 14/07/09 03:31 AM
Joined: Dec 2002
Posts: 31
N
Nekomusume Offline OP
Ameglian cow
OP Offline
Ameglian cow
N
Joined: Dec 2002
Posts: 31
Cutting and pasting of Japanese text works just fine in the edit box, but cutting from the channel/etc. window has a very high failure rate, resulting in a string of random characters.

Sometimes it works, but more often than not it doesn't. There seems to be some rules that govern when it will and won't fail, as trying to cut&past the same characters gives the same result each time.

End result, I often have to cut & paste random chunks of a line multiple times before I get one that has the part i need without being turned into gibberish.


Example, I have previously typed this line, and hit enter, so it's in the channel window: とても面白い

If I cut and paste the 面白 part by itself, i get this when I paste it: る擇逋ス

Cutting & pasting the ても gives 縺ヲ繧る.

But cutting & pasting the full phrase works perfectly, as do some other combinations of characters within the phrase.

Re: cutting & pasting Japanese text often doesn't work [Re: Nekomusume] #214023 14/07/09 03:46 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
I cannot reproduce this behaviour.

in mIRC type the following:

//echo -a $version $os $script(0) $dll(0) $md5($mircexe,2)

Paste the results here.

Also, what are your font/unicode settings set to?


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"