mIRC Home    About    Download    Register    News    Help

Print Thread
Joined: Jul 2009
Posts: 4
A
Self-satisified door
OP Offline
Self-satisified door
A
Joined: Jul 2009
Posts: 4
I am finding that my mIRC client is hanging randomly, taking up all of one of my cores' processing power. The issue occurs seemingly randomly but I've never had it happen while I was actively using the application. This issue started after upgrading to 6.35 about two weeks ago and happens usually after I've left the application idle for over an hour (but not always).

Attempted Fixes:
I tried reinstalling mIRC 6.35 after the upgrade by running the uninstall from "Programs and Features" in the control panel, deleting remaining mIRC files in the "Program Files" folder and in the "AppData/Roaming" folder.

Relevant information:
I have openSSL installed and never connect to a network without it. I've used the same SSL package for over 6 months with mIRC 6.32 without issue. I did reinstall it when I reinstalled mIRC, though, and it still functions as usual.


I'm using Windows Vista SP1, 32bit.
I'm using Windows Vista default firewall and Symantec AV Professional with auto-protection.
UAC and Windows Defender, etc etc default vista security etc.
I usually have multiple internet connected services, I'll expand if that's important.

//echo -a $md5($mircexe,2) $dll(0) returns 2f63a83968f9586fe4fb48134253619c 0

I do use one custom script, that I made myself, which I backed up and reintegrated when I re-set up my settings after the re-install. It is only loaded temporarily at start up at which time I've never experienced a hang; it's then unloaded after about 10 seconds.

I'm at a bit of a loss for what to do. Is there a known solution to this issue? (If so... I need to improve my googling skills.)

Last edited by Asandari; 11/07/09 02:12 AM.
Joined: Jul 2009
Posts: 4
A
Self-satisified door
OP Offline
Self-satisified door
A
Joined: Jul 2009
Posts: 4
Also, before anyone asks, my problem is not related to this issue (I don't think): https://forums.mirc.com/ubbthreads.php?ubb=showflat&Number=209146&page=1#Post209146

As I'd been using MANY more channels about 6 months ago on 6.3 without issue, all with SSL, and over many more servers. (About twice as many as my current).
The hang also occurs indefinitely (I've come back after a while to find that my mIRC was hanging and it's logs stopped logging 40 minutes ago). I always forcibly exit the program when this issue occurs.

Last edited by Asandari; 12/07/09 04:14 PM.
Joined: Jul 2006
Posts: 4,162
W
Hoopy frood
Offline
Hoopy frood
W
Joined: Jul 2006
Posts: 4,162
Have you tried this on completely clean install of mirc 6.35 and tried without using ssl ?


#mircscripting @ irc.swiftirc.net == the best mIRC help channel
Joined: Jul 2009
Posts: 4
A
Self-satisified door
OP Offline
Self-satisified door
A
Joined: Jul 2009
Posts: 4
The only error that could have occurred with my reinstall were from the fact that I didn't remove registry keys (that may not have been removed by the uninstaller, which apparently included my registration information, since I didn't have to reset it after I started up the fresh 6.35. I did have to reset all of my other settings though.)

I haven't tried using it without SSL or without installing SSL. Unfortunately, I'm too paranoid to use mIRC without SSL. I installed SSL by running the openssl-0.9.8k-setup.exe package as linked here: http://www.mirc.com/ssl.html. And setting it to install in the /program files/mirc folder. No other changes were made during the install process and it's the same install process I used when I first installed it with 6.3.

I'd also like to reiterate that the indefinite hangs are occurring while I am idle, not during start-up, connect, quit, close or activity (including having the window active).

Also, thank you for your response. smile

Joined: Jul 2006
Posts: 4,162
W
Hoopy frood
Offline
Hoopy frood
W
Joined: Jul 2006
Posts: 4,162
If you don't want to try on a completely clean install of mirc 6.35 with no script loaded, no dll and such and if you don't want to try without ssl (maybe it's related), there's nothing we can do to help you with this.Also, I think you should try with yours AV off during test...


#mircscripting @ irc.swiftirc.net == the best mIRC help channel
Joined: Jul 2009
Posts: 4
A
Self-satisified door
OP Offline
Self-satisified door
A
Joined: Jul 2009
Posts: 4
You're right I don't want to try without SSL, however it appears I've already done a clean install for as 'clean' as it will go. (As implied by this: "... mIRC makes no important changes to registry files or other Windows files that you have to remove...") from http://www.mirc.co.uk/help/uninstall.html

Also, I managed to, finally, find a related issue: https://forums.mirc.com/ubbthreads.php?ubb=showflat&Number=198935&page=3&PHPSESSID=
Unfortunately it doesn't look like a strict solution was found. I'll try letting mirc run with my AV disabled, though the fact that it doesn't seem specific to 6.35 throws me off a bit due to how long I was able to run mIRC without issue on 6.3.

Thanks again for your attention on this issue.

Last edited by Asandari; 13/07/09 01:02 AM.

Link Copied to Clipboard