mIRC Home    About    Download    Register    News    Help

Print Thread
Page 1 of 2 1 2
Typing lag mirc 6.35 #211978 07/05/09 12:04 AM
Joined: Oct 2007
Posts: 4
S
Shocky Offline OP
Self-satisified door
OP Offline
Self-satisified door
S
Joined: Oct 2007
Posts: 4
Hello,

I have noticed a major and annoying problem with latest mirc 6.35.
I am using windows 7 RC1 so it could be that but someone told me he noticed the same thing on windows vista but since mirc 6.32 or so.

The problem is when i type actively in the editbox or channels or query, sometimes i never see my characters. I have to wait up to 15 seconds to see them "coming". So this is kinda wierd... Anybody else having this problem?

Thanks

Re: Typing lag mirc 6.35 [Re: Shocky] #211983 07/05/09 12:37 AM
Joined: Jul 2006
Posts: 3,573
W
Wims Offline
Hoopy frood
Offline
Hoopy frood
W
Joined: Jul 2006
Posts: 3,573
More than weird, it not normal.
Window 7 could be the problem but I doubt it is the case here...
People on vista that noticed this too should try a clean mIRC 6.35 with no script loaded, usually script are cause of problems.


Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net
Re: Typing lag mirc 6.35 [Re: Shocky] #211984 07/05/09 12:47 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
Are you pasting input? More specifically are you pasting unicode input? mIRC usually freezes the first time it tries to render unicode if your font does not support unicode and font linking is on (might still occur without font linking as well). Note the default font (fixedsys) does not support unicode.

Also, in mIRC type:

//echo -a $md5($mircexe,2) $script(0) $dll(0) $version $os

Report the results here.

If you're running any scripts you should reinstall a fresh copy of mirc without scripts and verify that it still happens.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Typing lag mirc 6.35 [Re: argv0] #211985 07/05/09 01:06 AM
Joined: Oct 2007
Posts: 4
S
Shocky Offline OP
Self-satisified door
OP Offline
Self-satisified door
S
Joined: Oct 2007
Posts: 4
I am not pasting... it is during typing.
I currently have mircryption suite loaded as scripts.

Your command gives me:
877f45a0d205e409a7c2d4c87f03fe90 6 1 6.35 Vista

Thanks

Re: Typing lag mirc 6.35 [Re: argv0] #211989 07/05/09 05:10 AM
Joined: Oct 2005
Posts: 1,741
G
genius_at_work Offline
Hoopy frood
Offline
Hoopy frood
G
Joined: Oct 2005
Posts: 1,741
2f63a83968f9586fe4fb48134253619c 21 0 6.35 Vista

Re: Typing lag mirc 6.35 [Re: Shocky] #211990 07/05/09 06:43 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
You've directly modified the mIRC executable which violates the EULA (license agreement). We cannot offer you support. Download mIRC from http://www.mirc.com and try this on a COMPLETELY FRESH install of mIRC with no scripts running. I have a good feeling that without mirccryption modifying what you send and receive from the server, mIRC will likely render text a lot more responsively.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Typing lag mirc 6.35 [Re: Wims] #211996 07/05/09 01:03 PM
Joined: May 2009
Posts: 139
E
Excalibur Offline
Vogon poet
Offline
Vogon poet
E
Joined: May 2009
Posts: 139
No it isn't
I've been using Windows 7 for a long time and I had no issues with mIRC, it actually runs on Windows 7 as smooth as it runs on XP, if not better.


- Excalibur
- Good and Evil, there never is one without the other.
Re: Typing lag mirc 6.35 [Re: Excalibur] #211997 07/05/09 01:07 PM
Joined: Dec 2002
Posts: 2,012
R
RoCk Offline
Hoopy frood
Offline
Hoopy frood
R
Joined: Dec 2002
Posts: 2,012

Same here, no problems whatsoever on Win7.

~ Edit ~

x86 & x64


Re: Typing lag mirc 6.35 [Re: Shocky] #212029 08/05/09 08:58 PM
Joined: Mar 2007
Posts: 218
V
vexed2 Offline
Fjord artisan
Offline
Fjord artisan
V
Joined: Mar 2007
Posts: 218
I use mIRC 6.35 successfully on Windows 7 too. However, i noticed a typing lag on a script i started making, then while i was trying to work this out i also noticed on my dcx sbar, the timers were going up up 2's even though the timer was supposed to update every second. I don't know what the problem was to be exact, but i run AVG 8.5 so i set an exception to the whole mIRC directory C:\mIRCscript and clicked apply, and bingo! It fixed the typing lag and the delay in the timer. So obviously the realtime scanning must have had something to do with this and maybe it's because of how Windows 7 works now. I can't say with certainty, but it worked for me. smile

Re: Typing lag mirc 6.35 [Re: Shocky] #213046 16/06/09 04:21 AM
Joined: Jun 2009
Posts: 1
K
kogitsune Offline
Mostly harmless
Offline
Mostly harmless
K
Joined: Jun 2009
Posts: 1
I have this same sort of issue... I've already posted to a topic someone started on the Windows 7 forum but there's no replies at all so far.

I know it's not scripts because... mine has none besides the defaults. Tried clean installs-- It happens to me in every version back to 5.16 or so.

We found that it's specifically related to when a channel window is made inactive either through minimizing, alt+tab, clicking on the start menu, or switching away from the window in any manner. If you go back to mIRC and type quickly, it'll lag and sometimes not display until you move the mouse.

It types and displays perfectly until this is done.

This behaviour is also specific to each channel window (It doesn't happen in unique channel windows until you switch to them and change the active window).

I run AVG, so I also tried the exception mentioned earlier in this thread. I've also attempted to run it on compatibility modes for XP SP3 (The previous OS I used), SP2, Vista, and for kicks 2000 and 95. It makes no effect.

Otherwise it works beautifully, I've seen no other issues. As stated, it could be something in Windows 7, since it didn't do this to me in XP SP3-- But as I pointed out... the old versions around 5.16 and below don't do this.

Just for sake:
I'm currently using 6.35 edition re-installed
I'm running a Phenom II X4 955 3.2Ghz quad, 4Gb RAM, Windows 7 build 7100 RC, Sapphire Radeon 4870HD, Western Digital Caviar SATA 620Gb HD.

Last edited by kogitsune; 16/06/09 04:23 AM.
Re: Typing lag mirc 6.35 [Re: kogitsune] #213048 16/06/09 05:44 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
@kogitsune: In mIRC type:

//echo -a $md5($mircexe,2) $script(0) $dll(0) $version $os

Report the results here.

Also disable AVG entirely (yes, entirely) and try this again. It's far more likely that your anti-virus software is causing the problem than mIRC.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Typing lag mirc 6.35 [Re: argv0] #213079 17/06/09 02:31 PM
Joined: Dec 2008
Posts: 1,511
westor Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2008
Posts: 1,511
The same problem here with Windows XP SP3, getting lag on scripts!

3e9f2b048c960052d6230d4735c41622 8 1 6.35 XP

Re: Typing lag mirc 6.35 [Re: westor] #213081 17/06/09 02:34 PM
Joined: Jul 2006
Posts: 3,573
W
Wims Offline
Hoopy frood
Offline
Hoopy frood
W
Joined: Jul 2006
Posts: 3,573
You don't have a real copy of mIRC 6.35, try download it on mirc.com.Also, unload your scripts and your dll, you really should try on a clean install.

Last edited by Wims; 17/06/09 02:36 PM.

Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net
Re: Typing lag mirc 6.35 [Re: Shocky] #213906 11/07/09 07:19 PM
Joined: Jan 2007
Posts: 1,156
D
DJ_Sol Offline
Hoopy frood
Offline
Hoopy frood
D
Joined: Jan 2007
Posts: 1,156
I wonder what your computers specs are. Been using Vista for over a year and have never had this issue.

Re: Typing lag mirc 6.35 [Re: DJ_Sol] #213912 11/07/09 08:19 PM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
Both users who complained in this thread had modified versions of mIRC, so draw your own conclusions.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Typing lag mirc 6.35 [Re: argv0] #214260 26/07/09 08:50 PM
Joined: Aug 2007
Posts: 42
L
Lusht Offline
Ameglian cow
Offline
Ameglian cow
L
Joined: Aug 2007
Posts: 42
Ok, I tired.
Same annoying problem here, details:
2f63a83968f9586fe4fb48134253619c 23 0 6.35 Vista (it's win7 x32 actually)
Also, additional details:
http://img233.imageshack.us/i/details.png/
Just clean install, it is not modified copy. UTF-8 encoding&decoding (per channel settings) disabled, only UTF-8 display enabled.

Btw, I noticed that when lagging starts such interesting thing happens:
http://img233.imageshack.us/my.php?image=graph.png

If I will quickly change window to text editor - everything fine, no lagging when typing...

P.S. Under Vista it worked fine with the same set of scripts. Also, I don't have script which monitors on INPUT events or editbox state.

Last edited by Lusht; 26/07/09 08:51 PM.

"Do, or do not. There is no 'try'." - Yoda ('The Empire Strikes Back')
Re: Typing lag mirc 6.35 [Re: Lusht] #214262 26/07/09 09:07 PM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
How does a "clean install" contain 23 loaded scripts?

Any number of those 23 scripts could be the cause. Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.

Alternatively you can unload scripts until the problem goes away (if it does)-- the last unloaded script would be the cause, at which point we can figure out if it's the script or some incompatibility between those commands and Windows7.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Typing lag mirc 6.35 [Re: argv0] #214272 27/07/09 05:57 PM
Joined: Aug 2007
Posts: 42
L
Lusht Offline
Ameglian cow
Offline
Ameglian cow
L
Joined: Aug 2007
Posts: 42
Quote:
How does a "clean install" contain 23 loaded scripts?

I said it especially for you to prevent "oh-youre-using-modified-copy!" thingy.

Quote:
Any number of those 23 scripts could be the cause. Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.

TRIED already. Same issue happens.


"Do, or do not. There is no 'try'." - Yoda ('The Empire Strikes Back')
Re: Typing lag mirc 6.35 [Re: Lusht] #214295 28/07/09 05:19 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
I don't understand your response. If you tried this without scripts why did your post explicitly discuss the results *with* scripts?


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Typing lag mirc 6.35 [Re: argv0] #214323 28/07/09 09:07 PM
Joined: Aug 2007
Posts: 42
L
Lusht Offline
Ameglian cow
Offline
Ameglian cow
L
Joined: Aug 2007
Posts: 42
Quote:
I don't understand your response.

We can help here:

Quote:
Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.


Quote:
TRIED already. Same issue happens.


"Do, or do not. There is no 'try'." - Yoda ('The Empire Strikes Back')
Page 1 of 2 1 2