mIRC Home    About    Download    Register    News    Help

Topic Options
#21097 - 27/04/03 02:59 AM Blank Popup Instead of Sound
The_Meddler Offline
Self-satisified door

Registered: 27/04/03
Posts: 4
I am currently having a problem with mIRC 6.03 and any help would be appreciated.

For some time, I have been able to play, and hear others play, sounds in chatrooms, which we would transfer to each other via DCC. All of a sudden, my ability to hear the sounds stopped.

Instead of playing the sound, mIRC now displays a small popup window which has no content - it's just the bar from the top of a window, without even the window content you would normally get underneath it. This happens when I play a sound, or when someone else plays one. The only thing that can be done is to close the popup.

I've tried reinstalling mIRC with no luck and am pretty much out of ideas. Has anyone else come across this?

Top
#21098 - 27/04/03 08:05 AM Re: Blank Popup Instead of Sound
ParaBrat Offline
Planetary brain

Registered: 07/12/02
Posts: 3127
Loc: BratLand
one guess would be a script prob, maybe a dialog/pic window messed up. try typing /remote off and see if it still happens. (you can turn them back on with /remote on). Is there anything in what you see that could help identify the window that pops up? Is it with all sound file types? Wouldnt hurt to look thru your scripts to see if there's anything there that has splay or sound

Since mIRC doesnt play the sounds, but sends them to windows to handle, can you play those sounds directly in mediaplayer all right?

Needless to say, also wouldnt hurt to run a good virus scan or two especially if you have a script you didnt know you had, like with this one
_________________________
ParaBrat @#mIRCAide DALnet

Top
#21099 - 27/04/03 11:39 PM Re: Blank Popup Instead of Sound
The_Meddler Offline
Self-satisified door

Registered: 27/04/03
Posts: 4
/remote off and on make no difference to the problem, I'm afraid. I also scan for viruses regularly and have had no results. All my sounds play with no problems in Media Player (6.4, if that helps).

I've tried uninstalling mIRC, (hopefully) removing all trace of it, then reinstalling to a different directory, with the same result.

Again, any ideas would be most welcome & thanks for the suggestions ParaBrat.

Top
#21100 - 28/04/03 12:38 PM Re: Blank Popup Instead of Sound
ParaBrat Offline
Planetary brain

Registered: 07/12/02
Posts: 3127
Loc: BratLand
can you recall anything new you did/got just before this prob started? really does sound like a script error. Did you double check in file/options/sounds/requests to be sure mIRC has the correct directory for each type of sound? You tried with vanilla mIRC, no scripts at all?

Just for grins, go into windows explorer and double click on one of the sounds.. does it play ok?
_________________________
ParaBrat @#mIRCAide DALnet

Top
#21101 - 29/04/03 10:00 PM Re: Blank Popup Instead of Sound
The_Meddler Offline
Self-satisified door

Registered: 27/04/03
Posts: 4
mIRC is definitely pointing at the right directory, I keep all the sounds in mIRC/sounds (the default). Most are mp3's though there are a few wavs. The method I generally used to play them was via tools/aliases and assigning sounds to F-keys, although the problem persists with the more traditional /sound command. All sound files play fine via windows explorer and media player.

I'm sorry nothing's worked so far. Thanks for the efforts though.

Top
#21102 - 29/04/03 11:48 PM Re: Blank Popup Instead of Sound
ParaBrat Offline
Planetary brain

Registered: 07/12/02
Posts: 3127
Loc: BratLand
did you look thru all your remotes for anything lese with /sound in it? what do your aliases look like?
_________________________
ParaBrat @#mIRCAide DALnet

Top
#21103 - 08/05/03 11:59 PM Re: Blank Popup Instead of Sound
The_Meddler Offline
Self-satisified door

Registered: 27/04/03
Posts: 4
Sorry for the delay in replying. mIRC has taken to crashing when I play sounds now, so I'm hoping something in here rings a bell. I've searched through every file in the mirc folders, and here are the results:

mirc.ini contains:
[dragdrop]
n0=*.wav:/sound $1 $2-

aliases.ini:
n12=F1 /sound applause.mp3 plays canned applause.
n13=F2 /sound canned.mp3 plays canned laughter.
and so on up to F12. These are what my aliases look like, all 12 function keys have a sound on.

The only other mentions of /sound that come up are in chat logs. I hope some of this means something to you.

Top