mIRC Home    About    Download    Register    News    Help

Print Thread
Degraded Japanese cahacter handling #189583 09/11/07 04:20 AM
Joined: Nov 2007
Posts: 1
B
Bishibashi Offline OP
Mostly harmless
OP Offline
Mostly harmless
B
Joined: Nov 2007
Posts: 1
Compared with 6.16, 6.31 seems to have some bugs at handling Japanese or multibytes characters.

When the message is divided to plural lines, the first letter at the 2nd, 3rd... lines always display wrong character.
It may lose to display the first byte of the character.

I hope this issue soon fixed.

Thanks.

Re: Degraded Japanese cahacter handling [Re: Bishibashi] #189607 09/11/07 04:51 PM
Joined: Nov 2007
Posts: 1
W
Wallmit Offline
Mostly harmless
Offline
Mostly harmless
W
Joined: Nov 2007
Posts: 1
I can confirm this. In most cases (excluding when you try to copy what's already 文字化け'd) one can copy text normally, but not read it, though, but it's kind of annoying, like when you are on such networks like freenode, where people just tend to conduct "smart" conversations saying long sentences.

Re: Degraded Japanese cahacter handling [Re: Wallmit] #189609 09/11/07 05:11 PM
Joined: Nov 2007
Posts: 2
7
7teen Offline
Bowl of petunias
Offline
Bowl of petunias
7
Joined: Nov 2007
Posts: 2
I've seen this too! But it does not bother me :P Though it'd be cool if someone fixed it. I think smile


NEVER KNOWS BEST (FLCL^^)
Re: Degraded Japanese cahacter handling [Re: Bishibashi] #195315 22/02/08 01:52 AM
Joined: Feb 2008
Posts: 3
C
cartaeon Offline
Self-satisified door
Offline
Self-satisified door
C
Joined: Feb 2008
Posts: 3
I would just like to call attention to this bug report, as this issue remains as of 6.31, and at least for me is a show-stopper which significantly impacts my ability to use mIRC on a daily basis.

The basic issue on my end is that when using Japanese WITHOUT UTF8 enabled, as is the usual method on Japanese channels and networks, the character at the intersection of a line split becomes incorrectly decoded and split into two garbage ASCII characters. An example of this behavior can be seen here:


The point of attention here is the small 't' which can be seen on the third line down, which is being displayed instead of the correct Japanese character as seen further down on the UTF8 line. Occasionally this garbage text is more troublesome ASCII characters which can negatively affect all of the characters that follow.

I would be extremely pleased to see this fixed.

Re: Degraded Japanese cahacter handling [Re: cartaeon] #195316 22/02/08 01:55 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
Err,

It works with UTF8 on, yes? Can you not keep UTF8 on? If so, where's the problem / how is it a "show stopper"?


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Degraded Japanese cahacter handling [Re: argv0] #195329 22/02/08 05:31 AM
Joined: Feb 2008
Posts: 3
C
cartaeon Offline
Self-satisified door
Offline
Self-satisified door
C
Joined: Feb 2008
Posts: 3
UTF8 is not supported by most Japanese IRC clients, and thus networks and channels usually do not use that encoding. I cannot use UTF8 in this case.

I understand this may appear to be a small, minor problem, and I'm sure the number of people affected is small, but having nearly every single line of text partially messed up becomes ridiculously annoying after a while. It would just be nice not to have to use an outdated version to chat properly.

Re: Degraded Japanese cahacter handling [Re: cartaeon] #195333 22/02/08 06:20 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
There are multiple UTF8 settings in mIRC. There is a display only mode as well as a display and encode mode. I imagine that setting it to display only will render your local window properly while still sending non-utf8 to your japanese friends across the wire.

This should be an easy fix and can be done through the font dialog (View -> Font)


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: Degraded Japanese cahacter handling [Re: argv0] #195356 22/02/08 06:42 PM
Joined: Feb 2008
Posts: 3
C
cartaeon Offline
Self-satisified door
Offline
Self-satisified door
C
Joined: Feb 2008
Posts: 3
I appreciate the help, but Display Only is what the "non unicode" text is using in that screenshot, and it certainly does not display properly. UTF8 Display and Encode is what is used in the Unicode enabled example. The problem lies with the display of SJIS text (I believe that is what mIRC displays natively in the window)

And just to save extra hassle I will say now that none of the Message settings in mIRC options (SJIS/JIS conversion, etc) are acceptable for solving the issue. It simply appears to be degraded font/text/encoding handling introduced by some change in the engine over the past couple versions.

Thanks again for any help!

Re: Degraded Japanese cahacter handling [Re: cartaeon] #195368 22/02/08 10:03 PM
Joined: Oct 2004
Posts: 8,330
Riamus2 Offline
Hoopy frood
Offline
Hoopy frood
Joined: Oct 2004
Posts: 8,330
Strange. I thought there was a fix that handled issues with where lines wrapped. Maybe that fix only affected UTF8 and nothing else...


Invision Support
#Invision on irc.irchighway.net
Re: Degraded Japanese cahacter handling [Re: Bishibashi] #198026 19/04/08 09:08 AM
Joined: Dec 2002
Posts: 4,753
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,753
Thanks this issue has been fixed for the next version.