mIRC Home    About    Download    Register    News    Help

Print Thread
Hotlink problem.. again #156695 19/08/06 01:29 PM
Joined: Feb 2006
Posts: 164
V
vexed Offline OP
Vogon poet
OP Offline
Vogon poet
V
Joined: Feb 2006
Posts: 164
Code:
 on ^1:HOTLINK:*:*:{
  if ($1 == [whois]) || ($1 == [chat])  || ($1 == [close]) || ($1 == [send]) || ($1 == [ignore]) || ($1 == [names]) || ($1 == [here])  || ($1 == [clones]) return
  halt
}

on *:HOTLINK:[clones]:#:{ .kb $active }

ial {
  set %i 1
  set %ial.nicks.test ""
  while ($ial($address($1,2),%i).nick != $null) {
    set %ial.nicks.test %ial.nicks.test $ial($address($1,2),%i).nick 
    inc %i
  }
  dec %i
  set %ial.stuff %i
} 

kb {  
  .ial $1 
  .mode # - $+ $str(o,%ial.stuff) %ial.nicks.test
  .prop $chan ownerkey $randz $crlf access $chan clear owner
  var %i = 1
  while ($gettok(%ial.nicks.test,%i,32) != $null) {
    .ban -k  $chan $ifmatch 4 $2-
    inc %i
  } 
}
 


The /kb <nick> works manually and gets their clones, but using that hotlink event doesn't seem to work.
Apreciate any help!

Re: Hotlink problem.. again #156696 19/08/06 11:31 PM
Joined: Sep 2003
Posts: 4,230
D
DaveC Offline
Hoopy frood
Offline
Hoopy frood
D
Joined: Sep 2003
Posts: 4,230
A few things, /IAL exists as a real command, so using it as an alias isnt the best idea
your /IAL alias is ment to be passed $1 as a nick i assume, and it gets that from the alias KB's first lne.
Now in he hotlink you pass alias KB the active window as $1, and no $2 value (used later in it), so no wonder its all coming apart!