mIRC Home    About    Download    Register    News    Help

Print Thread
link bug? #153902 24/07/06 11:54 AM
Joined: Mar 2003
Posts: 612
B
billythekid Offline OP
Fjord artisan
OP Offline
Fjord artisan
B
Joined: Mar 2003
Posts: 612
i am finding strange behaviour with the following hotlink format.

if someone(or yourself) does the following line...

/notice yournick Thanks for joining #channel, yournick We appreciate it.

everything after the # becomes the hotlink for #channel including the right click menu and even yournick.(on the outgoing and incoming notice) normally the yournick(were it your own nickname) would give the menu/hotlinks for the nicklist.

the hotlink doesnt happen when the same line is echo'd instead of noticed.

anyone got a reason for this?

btk

Last edited by billythekid; 24/07/06 11:56 AM.

billythekid
Re: link bug? #153903 24/07/06 12:43 PM
Joined: Dec 2002
Posts: 1,527
L
landonsandor Offline
Hoopy frood
Offline
Hoopy frood
L
Joined: Dec 2002
Posts: 1,527
This could be a script malfunction. I turned my remotes off and tried it and only my nickname (for the nicklist) and the channel name (for the channel list) worked. I checked both sides of my nickname and none of it lit up. I turned my remotes back on 9cause I have a custom /notice script) and even in the @window the #channel menu only fired on #channel and not my nick or any other text outside of the #channel word. mirc 6.17 here


Those who fail history are doomed to repeat it
Re: link bug? #153904 24/07/06 04:01 PM
Joined: Apr 2004
Posts: 218
P
PhantasyX Offline
Fjord artisan
Offline
Fjord artisan
P
Joined: Apr 2004
Posts: 218
I'm unable to reproduce this. It seems a personal script my be causing the confliction. I tryed in channel and status windows. Nothing on my end seemed to malfunction. =)


Live to Dream & Dream for Life
Re: link bug? #153905 24/07/06 04:36 PM
Joined: Mar 2003
Posts: 612
B
billythekid Offline OP
Fjord artisan
OP Offline
Fjord artisan
B
Joined: Mar 2003
Posts: 612
ok thanks all, i'll try some more tests...

btk


billythekid
Re: link bug? #153906 24/07/06 04:38 PM
Joined: Mar 2003
Posts: 612
B
billythekid Offline OP
Fjord artisan
OP Offline
Fjord artisan
B
Joined: Mar 2003
Posts: 612
even after typing /remote off i get the same result.

how bizarre, i hate being the freak! lol

btk


billythekid
Re: link bug? #153907 24/07/06 04:52 PM
Joined: Mar 2003
Posts: 612
B
billythekid Offline OP
Fjord artisan
OP Offline
Fjord artisan
B
Joined: Mar 2003
Posts: 612
ok i have no idea how to reproduce other than, the first line here was pasted and teh second was hand typed, only the pasted one produces the strange behaviour...

[5:52PM] -> -billythekid- Thanks for joining #channel, billythekid We appreciate it.
[5:52PM] -billythekid- Thanks for joining #channel, billythekid We appreciate it.
[5:52PM] -> -billythekid- Thanks for joining #channel, billythekid We appreciate it.
[5:52PM] -billythekid- Thanks for joining #channel, billythekid We appreciate it.

i thought there might be some $chr(160)s in there joining it all together or something...??

in which case it's expected behaviour and not a bug at all... oh, here is the copied line copied straight from my mirc...

/notice billythekid Thanks for joining #channel, billythekid We appreciate it.

i see it jumped down a line(wrapped)during this posting by itself, which would suggest that its coming as one word(#channel, billythekid We appreciate it.) but when you double click on it it goes to #channel (is 160 an allowed character in a channel name?)

anyhow this was a bit of a ramble, anyone find anything??

btk


billythekid
Re: link bug? #153908 25/07/06 01:43 AM
Joined: Dec 2002
Posts: 1,527
L
landonsandor Offline
Hoopy frood
Offline
Hoopy frood
L
Joined: Dec 2002
Posts: 1,527
try /!remote off in case the /remote off default was changed and try it again


Those who fail history are doomed to repeat it