mIRC Home    About    Download    Register    News    Help

Print Thread
"Target change too fast. Please wait xx seconds" #152346 29/06/06 09:22 PM
Joined: Apr 2006
Posts: 464
O
OrionsBelt Offline OP
Fjord artisan
OP Offline
Fjord artisan
O
Joined: Apr 2006
Posts: 464
Hi all,

I just noticed a new problem, with joining a lot of channels.
At the moment, I'm joining like 16 or more channels.
But now, mIRC comes with this error:
"Target change too fast. Please wait 43 seconds."
And the script 'halts'.... confused

I would like to solve it.
For example like the $play command, joining the channels with 2 seconds (or more) delay. As long as it would run/join on a stable way.

Code:
raw 396:*Nick.hostname.org is now your hidden host:{
  join #xxx1
  join #xxx2
  join #xxx3
  join #xxx4
  join #xxx5
  join #xxx6
  join #xxx7
  join #xxx8
  join #xxx9
  join #xxx10
  join #xxx11
  join #xxx12
  join #xxx13
  join #xxx14
  join #xxx15
  join #xxx16
  join #xxx17
  join #xxx18
  join #xxx19
  join #xxx20
}


Anyone with idea's?
Thx for the help

Last edited by OrionsBelt; 29/06/06 09:23 PM.
Re: "Target change too fast. Please wait xx second #152347 29/06/06 09:50 PM
Joined: Jul 2005
Posts: 40
K
Karas Offline
Ameglian cow
Offline
Ameglian cow
K
Joined: Jul 2005
Posts: 40
maybe with some timers ?

{
join #chan1,#chan2,#chan3
.timer 1 3 join #chan4,#chan5,#chan6
.timer 1 5 join #chan7,#chan8,#chan9
.timer 1 7 join #chan10,#chan11,#chan12
.timer 1 9 join #chan13,#chan14,#chan15
}

dunno the delay.. test it xD


j0k3r @ k4s.ch
Re: "Target change too fast. Please wait xx seconds" #152348 30/06/06 04:33 AM
Joined: Oct 2005
Posts: 91
T
truguce Offline
Babel fish
Offline
Babel fish
T
Joined: Oct 2005
Posts: 91
i use raws to join all my chans. You just need to set how to join the first chan, I have it set to join after my vhost gets set.
Code:
#rawww on
on ^*:notice:Your vhost*:*: {
  if ($nick == HostServ) {
    .enable #rawjoin
    timerbotzjoin 1 20 /join #chan1
  }
}
#rawww end
#rawjoin off
raw 329:*: { 
  if ($2 == #chan1) /join #chan2 
  if ($2 == #chan2) /join #chan3
  if ($2 == #chan3) /join #chan4
  if ($2 == #chan4) .disable #rawjoin
}
#rawjoin end

That has always worked for me.

Re: "Target change too fast. Please wait xx seconds" #152349 30/06/06 06:45 PM
Joined: Apr 2006
Posts: 464
O
OrionsBelt Offline OP
Fjord artisan
OP Offline
Fjord artisan
O
Joined: Apr 2006
Posts: 464
Well, I tried using the raws, but in my case it halts after joining like 2 channels out of 18.

Also the auto-join on invite remains operational, even though I switch it off.

Can anyone help me some more with this one?
Thx a lot.

Re: "Target change too fast. Please wait xx seconds" #152350 30/06/06 09:56 PM
Joined: Apr 2006
Posts: 464
O
OrionsBelt Offline OP
Fjord artisan
OP Offline
Fjord artisan
O
Joined: Apr 2006
Posts: 464
Ok, so now I just use the original script, but added a timer on every join in the list:

.timer 1 5 join #chan1
.timer 1 10 join #chan2
.timer 1 20 join #chan3
---some more here---
.timer 1 180 join #chan19

Would have expected there was a more slick way to do this, but I guess this also solves the problem.

Re: "Target change too fast. Please wait xx second #152351 30/06/06 10:36 PM
Joined: Aug 2004
Posts: 7,252
R
RusselB Offline
Hoopy frood
Offline
Hoopy frood
R
Joined: Aug 2004
Posts: 7,252
I knew I'd written something like this before. Took me a bit to find it.
Code:
 on *:connect:{
  var %a = 1, %b = $ini(Auto-Join.ini,$network,0)
  while %a <= %b {
    .timer 1 $calc(10 * %a) join $readini(Auto-Join.ini,n,$network,%a)
    inc %a
  }
}
alias autojoin {
  var %a = 1, %b = $0
  while %a <= %b {
    .writeini -n Auto-Join.ini $network $gettok($1-,%a,32)
    inc %a
  }
}
 


Alias usage: /autojoin <list of channels separated by spaces>

You can keep separate lists of channels to join on a network by network basis.

If the 10 multiplier is insufficient, and I know it is on some networks, just adjust the multiplier as necessary until you find a number that works.

Re: "Target change too fast. Please wait xx second #152352 01/07/06 10:59 AM
Joined: Apr 2006
Posts: 464
O
OrionsBelt Offline OP
Fjord artisan
OP Offline
Fjord artisan
O
Joined: Apr 2006
Posts: 464
Thx for the help RusselB.
But I get an error message when using the alias.

It tells me:
* /writeini: insufficient parameters (line 4, testing.mrc)

The writeini command is missing a value.

I changed it to:
.writeini -n Auto-Join.ini $network $gettok($1-,%a,32) on

But what value should the channels have?

Re: "Target change too fast. Please wait xx second #152353 01/07/06 05:49 PM
Joined: Aug 2004
Posts: 7,252
R
RusselB Offline
Hoopy frood
Offline
Hoopy frood
R
Joined: Aug 2004
Posts: 7,252
Ooops..sorry..if you change the writeini line to
Code:
 .writeini -n Auto-Join.ini $network $gettok($1-,%a,32) $gettok($1-,%a,32)
 

It should work. Sorry, I missed that last parameter in the copy/paste

Re: "Target change too fast. Please wait xx second #152354 02/07/06 03:00 AM
Joined: Apr 2006
Posts: 464
O
OrionsBelt Offline OP
Fjord artisan
OP Offline
Fjord artisan
O
Joined: Apr 2006
Posts: 464
Aha, thx for the help again RusselB.
I'll play with it in the morning a bit, to tired now smile

Thx man.