mIRC Home    About    Download    Register    News    Help

Print Thread
UTF8 bug #144533 11/03/06 11:18 AM
Joined: Mar 2006
Posts: 3
A
Amidos Offline OP
Self-satisified door
OP Offline
Self-satisified door
A
Joined: Mar 2006
Posts: 3
Hi.
i'm not sure if it is bug or not. but following thing is happening.
i activate UTF8 but still can`t type some letters. their codes are 0601 and 0351 (ə , ş). i am user from Azerbaijan and if i add Azeri(latin) to my languge in XP and select it. the key > types ş and key " types ə on notepad or Wordpad etc.. but can`t type them on mirc. Strange thing is if i copy/past them from notpad or web , or using alt+0601 or alt+0351 then it works fine. But can`t type it with one key. plz check it.

Best rgds,

Amid

Re: UTF8 bug #144534 11/03/06 10:25 PM
Joined: Oct 2003
Posts: 18
M
Mona_Payne Offline
Pikka bird
Offline
Pikka bird
M
Joined: Oct 2003
Posts: 18
Have you enabled Multibyte editbox? (it's in options -> IRC -> Messages)

Many complex languages need it and it doesn't hurt non-complex languages either, so I wonder why it's not the default setting..

Re: UTF8 bug #144535 12/03/06 10:38 AM
Joined: Sep 2005
Posts: 2,878
H
hixxy Offline
Hoopy frood
Offline
Hoopy frood
H
Joined: Sep 2005
Posts: 2,878
I was trying to help him on IRC. He has multibyte editbox on, UTF-8 display on, UTF-8 in the font dialog set to Display and Encode.

Re: UTF8 bug #144536 12/03/06 12:50 PM
Joined: Oct 2003
Posts: 110
D
DeathWolf Offline
Vogon poet
Offline
Vogon poet
D
Joined: Oct 2003
Posts: 110
both work for me using alt+601 or alt+0601

I am under a japanese windows xp, using japanese input, my options are multibyte display off, multibyte editor on, sjis conversion off, process ANSI off, utf-8 display on
And in the chan: utf-8 on for encode and display(and my script it set to japanese with arial ms unicode)

Last edited by DeathWolf; 12/03/06 12:51 PM.
Re: UTF8 bug #144537 12/03/06 01:17 PM
Joined: Sep 2005
Posts: 2,878
H
hixxy Offline
Hoopy frood
Offline
Hoopy frood
H
Joined: Sep 2005
Posts: 2,878
You'll notice he said it works fine if he uses the numpad. It doesn't work when he hits the " or > keys.

Re: UTF8 bug #144538 12/03/06 03:16 PM
Joined: Mar 2006
Posts: 3
A
Amidos Offline OP
Self-satisified door
OP Offline
Self-satisified door
A
Joined: Mar 2006
Posts: 3
yes as hixxy said i have multibyte editbox on utf8 on and so on.. everything right just can`t type that letters. all others works fine. and yes i can type them using alt+numpad but i want use 1 key < and ".
best,

Re: UTF8 bug #144539 12/03/06 07:47 PM
Joined: Oct 2003
Posts: 18
M
Mona_Payne Offline
Pikka bird
Offline
Pikka bird
M
Joined: Oct 2003
Posts: 18
Can you type the characters from keyboard in Notepad?

I think this is related to the fact that some of the newest languages (read: keyboard layouts) that Windows supports contain keys which are only defined through Unicode. In other words, there *isn't* a legacy codepage with those characters. If you press one of those keys, the application only gets a WM_UNICHAR message and not a WM_CHAR one (IIRC).

It could be that mIRC reads keypresses in a way which doesn't recognize the aforementioned characters. Obviously cut'n'paste bypasses this limitation, because it "directly" feeds the characters into the editbox.

Re: UTF8 bug #144540 17/03/06 03:18 PM
Joined: Mar 2006
Posts: 3
A
Amidos Offline OP
Self-satisified door
OP Offline
Self-satisified door
A
Joined: Mar 2006
Posts: 3
Yes i can type characters in notepad. it works just fine evrywhere except mirc.

Re: UTF8 bug #144541 06/08/06 06:32 PM
Joined: Aug 2006
Posts: 1
D
Dashiva Offline
Mostly harmless
Offline
Mostly harmless
D
Joined: Aug 2006
Posts: 1
I had the same problem, but with regular ASCII characters. t, h, c, and v did not register. The capital versions worked fine, and problem only occured in mIRC.

Restarting mIRC fixed it, somehow.


"Don't worry; the Universe IS out to get you."