mIRC Home    About    Download    Register    News    Help

Print Thread
6.17 text wrap bug for utf8 #143982 04/03/06 07:35 AM
Joined: Mar 2006
Posts: 12
M
MKamermans Offline OP
Pikka bird
OP Offline
Pikka bird
M
Joined: Mar 2006
Posts: 12
mIRC 6.17 has a text wrapping bug when utf8 is turned on to "display" (or display and encode) in a channel that uses certain fonts, where it seems to wrap the text regardless of whether the wrap breaks up a character consisting of two or more bytes.

As example, the following screenshot using the japanese enabled fixedsys on windows XP (the only difference between the lines is the number of leading ascii spaces): http://www.nihongoresources.com/downloads/mircgarble.PNG

Resizing mIRC or the channel window will make garbled sentences legible but will then of course wrap certain long sentence that showed fine before incorrectly.

It is uncertain whether this bug has anything to do with the width of the font being fixed or not, as MS UI Gothic also has this problem but Courier does not, for instance.

confirm bug?

Re: 6.17 text wrap bug for utf8 #143983 08/03/06 09:44 PM
Joined: Oct 2003
Posts: 18
M
Mona_Payne Offline
Pikka bird
Offline
Pikka bird
M
Joined: Oct 2003
Posts: 18
I am seeing the same bug. The deciding factor is the "Script" selection in the /font dialog. If it's set to Japanese, the text wrap bug occurs. If it's set to Western (European), the bug does not occur.

Other than the text wrap bug, all UTF-8 characters display fine with both scripts.

Re: 6.17 text wrap bug for utf8 #143984 12/03/06 07:14 AM
Joined: Mar 2006
Posts: 12
M
MKamermans Offline OP
Pikka bird
OP Offline
Pikka bird
M
Joined: Mar 2006
Posts: 12
In fact it seems to be a problem not just with Japanese, but all CJK scripts as well as the Symbol script (tested using the two main free full unicode set implementing fonts "bitstream cyberbit" and "code2000").

Re: 6.17 text wrap bug for utf8 #143985 12/03/06 08:35 PM
Joined: Oct 2003
Posts: 18
M
Mona_Payne Offline
Pikka bird
Offline
Pikka bird
M
Joined: Oct 2003
Posts: 18
Steps to reproduce this bug:

1) Install clean 6.17
2) In Options->IRC->Messages: Check multibyte display, multibyte editbox and utf-8 display. (I installed on a Western European system so the multibyte options weren't checked by default).
3) Connect to a server, join a channel.
4) Type /font in the channel window. Select MS Gothic, MS PGothic or MS UI Gothic. Choose "Japanese" as the script. Set UTF-8 to "display and encode".
5) Enter a long line of Japanese text. Pretty much anything will do. (For example copy something from the Japanese Wikipedia)
6) Slowly resize the window horizontally. The line will corrupt at some widths and look fine at others.