mIRC Home    About    Download    Register    News    Help

Print Thread
strange results from editbox #142980 20/02/06 03:51 PM
Joined: Aug 2004
Posts: 24
W
Wwhat Offline OP
Ameglian cow
OP Offline
Ameglian cow
W
Joined: Aug 2004
Posts: 24
When I paste arabic into the editbox it displays as arabic however when I press enter it is not arabic, looks like thai or something, I tried several unicode fonts.
it seems there's a disparity in general bewteen the font used in the editbox and in channel, I tried various checkboxes but it remains the same, starts to smell like a bug to me.

Re: strange results from editbox #142981 20/02/06 03:54 PM
Joined: Sep 2005
Posts: 2,881
H
hixxy Offline
Hoopy frood
Offline
Hoopy frood
H
Joined: Sep 2005
Posts: 2,881
This was happening to me before I had the "utf8" option in the font selection dialog (View > Font) set to "Display and Encode"

Re: strange results from editbox #142982 20/02/06 05:46 PM
Joined: Aug 2004
Posts: 24
W
Wwhat Offline OP
Ameglian cow
OP Offline
Ameglian cow
W
Joined: Aug 2004
Posts: 24
default I get '??????' display I also get '?????' display and decode I get the wrong letters.

Re: strange results from editbox #142983 20/02/06 06:27 PM
Joined: Aug 2004
Posts: 24
W
Wwhat Offline OP
Ameglian cow
OP Offline
Ameglian cow
W
Joined: Aug 2004
Posts: 24
I found a fix, seems that although unicode fonts like fixedsys excelsior have arab etc symbols it doesn't display right without installing 'support for asian languages' in windows control panel language options.
I noticed that notepad when set to unicode and using a unicode font had the same issue in displaying pastes wrong.
It is strange however that mirc's editbox did show it right even without the asian language support enabled, that threw me a bit.