mIRC Home    About    Download    Register    News    Help

Print Thread
auto op control bug? #139906 19/01/06 08:10 PM
Joined: Jan 2006
Posts: 2
E
eshock Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
E
Joined: Jan 2006
Posts: 2
In the op control list in the address book i added two channels (#test1, #test2) with the mask *!*@* that everbody who joined the channels get @. The problem is the second and descending channels in the list dont work. Of course the control is enabled.
I tested it with v6.03, v6.12 and v6.16.

So my question is it a bug or a feature?

Re: auto op control bug? #139907 20/01/06 04:08 AM
Joined: Jan 2005
Posts: 187
Brax Offline
Vogon poet
Offline
Vogon poet
Joined: Jan 2005
Posts: 187
With v6.16

/aop *!*@* #aopTest1,#AopTest2
also
/aop *!*@* #aopTest1,#aopTest2,#aopTest3,#aopTest4,#aopTest5,#aopTest6

All works like intended.
Every user who joins will be opped by me.

I would say it's somekind of malfunction in your end.


echo -a $signature
Re: auto op control bug? #139908 20/01/06 06:20 AM
Joined: Aug 2004
Posts: 7,252
R
RusselB Offline
Hoopy frood
Offline
Hoopy frood
R
Joined: Aug 2004
Posts: 7,252
The problem is the space between the channel names.
Quote:
(#test1, #test2)
should be #test1,#test2

Re: auto op control bug? #139909 20/01/06 01:33 PM
Joined: Jan 2006
Posts: 2
E
eshock Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
E
Joined: Jan 2006
Posts: 2
an example for the problem:
when u add channels for auto op over the address book control dialog (important) like

1. entry
Address: *!*@*
Channels: #test01
Network: TestNET

2. entry
Address: *!*@*
Channels: #test02
Network: TestNET

and so on ... only the first one works. /aop is clever and puts all the channels in one entry. i wasnt ;-)