mIRC Home    About    Download    Register    News    Help

Print Thread
Page 1 of 3 1 2 3
enable identd #118 07/12/02 07:44 PM
Joined: Dec 2002
Posts: 3,127
P
ParaBrat Offline OP
Hoopy frood
OP Offline
Hoopy frood
P
Joined: Dec 2002
Posts: 3,127
Due to abuse, if you are on many isps, on DALnet and some other networks you must have identd enabled. At http://kline.dal.net/exploits/ident.htm you will see the Ident FAQ on this, and to the left you will find links, click on the one that says Windows Identd for step by step how to enable identd in mIRC and links to standalone identd servers which may solve your problem. (even tho this is on DALnet's website, you can still find helpful info regardless of the network you are on)

Be sure you are not blocking port 113 with firewall (including the one with WinXP, see http://www.mirc.org/xpdcc/default.htm (and note that in v6.14 dcc ports were moved to connect/options, click the advanced button) for help with that) or router. You can find the same info here and here.
Windows XP Service Pack 2 users will find a new Windows Firewall with a slightly new interface. Please see this page for help or this guide. Do note, if you are only going to open port 113 rather than make an entire exception for mIRC, choose 'TCP'.

If you have a router and you need to forward port 113, then it depends on the router you have. It's a good idea to read the manual, however, see if your router is listed at http://www.portforward.com/routers.htm and see if they have instructions for yours. (Thanks Danthemandoo for that link)

The latest versions of Norton Antivirus have an "Internet Worm Protection" feature which may block port 113. To disable it, open NAV and click on 'Options'. Under 'Internet' go to 'Internet Worm Protection' and uncheck the box.

If identd has worked for you in the past and suddenly isn't on DALnet, read http://toidyman.net/identd.html.

If you are receiving an error message such as this:

"Your username is invalid.
Connect with your real username, in lowercase.
If your mail address were foo@bar.com, your username would be foo."


Or

"Closing Link: 0.0.0.0 (Invalid username [ ])"

..then you will need to edit your E-mail address settings or your IdentD. Make sure that you are not using any special characters such as $, %, ^, * in your email address or IdentD. To check your email address settings go to ALT+O > Connect and check the email address box.
To check your IdentD settings go to ALT+O > Connect > IdentD. Check the box next to 'User ID'.

Also make sure that everything in both those boxes is in lowercase (no CAPS). If it still doesn't work then try removing numbers and double check you have no other special characters. Remember that a script or a virus could be changing your IdentD automatically and that could be causing you problems. If it's a script you will need to unload the script from your remotes. If you think it may be a virus then see this thread and use 2-3 virus scanners to secure your system.

If the problem still persists then you're going to need to contact the network administration. Remember, this error message isn't given to you by mIRC, mIRC is just a client. The server of the network is actively refusing your connection due to your settings. You will need to go to your network's website and look for contact emails. If you don't know the network's website, search on Google.

You can find further help with this error message on this page. If you are a GameSurge user see their forums. If you are a Quakenet user see this page.

Last edited by Mentality; 15/05/05 02:59 PM.

ParaBrat @#mIRCAide DALnet
Using Triggered Ports #119 08/10/03 01:55 PM
Joined: Sep 2003
Posts: 9
E
erikw Offline
Nutrimatic drinks dispenser
Offline
Nutrimatic drinks dispenser
E
Joined: Sep 2003
Posts: 9
Some routers will let you use triggered port mapping. It allows incoming port 113 connections to go to multiple computers on your network. That way you can use mIRC from multiple computers. Triggered port mapping listens for messages from your computers, that have a specific destination port, or range of ports.

For example, you can tell the router to trigger a port mapping when it sees a connection message for port 6667, which is usually how you connect to an IRC server. You also tell the router to map port 113 to any computer that causes the trigger.

Unfortunately some routers don't have the triggered port feature, or it doesn't work right with port 113. I'm not sure why port 113 is such a problem, but please complain to the router manufacturer if they don't support port 113, or it doesn't work correctly.

Re: enable identd #120 02/01/04 12:47 PM
Joined: Jan 2004
Posts: 3
S
sailor_olimpus Offline
Self-satisified door
Offline
Self-satisified door
S
Joined: Jan 2004
Posts: 3
i don't know what to do, i've working with irc.mircx.com and this is the first time, several people told me that maybe i'm banned, but why? i didn't do anything!!! please help me!

Re: enable identd #121 03/01/04 09:24 PM
Joined: Dec 2002
Posts: 3,127
P
ParaBrat Offline OP
Hoopy frood
OP Offline
Hoopy frood
P
Joined: Dec 2002
Posts: 3,127
Without knowing exactly what is happening to you, its hard to just guess. What exactly happens? What msgs do you get?

If its a msg telling you to enable identd, some networks have had so many probs from users from certain providers that they insist all users from those providers (the ppl you pay for your internet service) enable identd.

Banning may not be aimed at you specifically, but on all ppl within a certain ip range and you are getting caught in it.


ParaBrat @#mIRCAide DALnet
Re: enable identd #122 05/01/04 11:20 AM
Joined: Jan 2004
Posts: 3
S
sailor_olimpus Offline
Self-satisified door
Offline
Self-satisified door
S
Joined: Jan 2004
Posts: 3
thanks for answering!

Re: enable identd #123 05/01/04 08:52 PM
Joined: Dec 2002
Posts: 3,127
P
ParaBrat Offline OP
Hoopy frood
OP Offline
Hoopy frood
P
Joined: Dec 2002
Posts: 3,127
you're welcome!


ParaBrat @#mIRCAide DALnet
Re: enable identd #124 06/01/04 09:53 PM
Joined: Jan 2004
Posts: 1
K
KST Offline
Mostly harmless
Offline
Mostly harmless
K
Joined: Jan 2004
Posts: 1
I have question about trigger port
what do i put in "Trigger Start Port" box and "Trigger End port" and Public port ??? Thanks for your help ..

Re: enable identd #125 14/01/04 01:42 AM
Joined: Jan 2004
Posts: 2
L
LillyLan422 Offline
Bowl of petunias
Offline
Bowl of petunias
L
Joined: Jan 2004
Posts: 2
Hi! I have a question on identd. I was told to identify or identd myself with mIRC. I ve tried everything to identd myself through mIRC help and through the website you had posted. But nothing works. I'm getting 'No Ident response' when I connect to mIRC. How can I identd myself? Please help!

Re: enable identd #126 14/01/04 01:46 AM
Joined: Jan 2003
Posts: 1,063
D
Doqnach Offline
Hoopy frood
Offline
Hoopy frood
D
Joined: Jan 2003
Posts: 1,063
it is possible that you use a firewall/router which does not let you use the identd. you need port 113 open for relay

for most networks it's no problem if you can't ident, it just uses the part in front of the @ of the email address you filled in.

make sure that the part in front of the @ of that email address is all lowercase without any special characters to be sure it works


If it ain't broken, don't fix it!
Re: enable identd #127 14/01/04 05:23 AM
Joined: Jan 2004
Posts: 2
L
LillyLan422 Offline
Bowl of petunias
Offline
Bowl of petunias
L
Joined: Jan 2004
Posts: 2
Hi! It's me again. Okay, I did what you said. But what happen if the part in front of the @ of the email address I filled in is short by one word or number in the mIRC option/connection/Identd.
This is what it said when I connect.

-irc.mircx.com- *** Looking up your hostname...
-
-irc.mircx.com- *** Found your hostname, cached
-
-irc.mircx.com- *** Checking Ident
-
-irc.mircx.com- *** No Ident response

Thank alot for helping!!!

Re: enable identd #128 15/02/04 12:36 PM
Joined: Feb 2004
Posts: 714
Z
Zyzzyx26 Offline
Hoopy frood
Offline
Hoopy frood
Z
Joined: Feb 2004
Posts: 714
Hello there smile

I was pointed to this forum by a friend, who was helping me with my identd problem.
I have a network here at home...just 3 computers. If i connect as the main computer, i get identified, but my Userid is not the one i set.
If i connect as the client, i don't get identified, but my Userid remains as the one i set. What's going on?
I have a proxy program called AnalogX., no firewall and my router doesnt block the port 113 (i checked already smile
Help me please! Thanks smile


"All we are saying is give peace a chance" -- John Lennon
Re: enable identd #129 19/02/04 05:27 AM
Joined: Feb 2004
Posts: 3
W
whoa Offline
Self-satisified door
Offline
Self-satisified door
W
Joined: Feb 2004
Posts: 3
thanks is good

[08:13] -dragons.ca.us.dal.net- *** Got Ident response
- cool

Re: enable identd #130 22/02/04 05:39 PM
Joined: Apr 2003
Posts: 3
W
worfking Offline
Self-satisified door
Offline
Self-satisified door
W
Joined: Apr 2003
Posts: 3
i have a d-link 614 router and have no problems irc or irq for that matter.


LIFE'S NOT A GUARANTEE, IT'S AN OPTION.
identd errors #131 31/03/04 07:34 AM
Joined: Mar 2004
Posts: 1
Y
yujin Offline
Mostly harmless
Offline
Mostly harmless
Y
Joined: Mar 2004
Posts: 1
hi, i posted a message but i get it got lose, hopefully i am not double posting.
I have a problem connecting to channel everything i do, it say
"you must register or identify to you nickname to enter this channel"
i have register and indendt my nickname.
can anyone help me


Nothin is wat it seez
Re: identd errors #132 31/03/04 06:33 PM
Joined: Jun 2003
Posts: 5,024
M
Mentality Offline
Hoopy frood
Offline
Hoopy frood
M
Joined: Jun 2003
Posts: 5,024
That message is unrelated to IdentD.

Some networks have a +R (or +r) channel mode which means only registered/identified users can join - not all networks have this.

The problem might be a desynch. Reconnect to a different server (try /links for a list) and then identify again. Also make sure you use your registered nickname and that you don't just identify from a nickname different from your registered one.

Their may be other factors involved for the network you use - we are not affiliated with any one channel, server or network and so can't possible know about all of them. The best thing to do is to ask in the network's #Help channel or check out the network's website. If you don't know the website address, search Google.

Best of luck smile

Regards,


Mentality/Chris
enable identd/autokill #133 08/04/04 11:18 AM
Joined: Mar 2004
Posts: 3
M
Miss_R Offline
Self-satisified door
Offline
Self-satisified door
M
Joined: Mar 2004
Posts: 3
hello its me again i cant still connect to mirc dalnet. im using windowsxp and the problem is everytime i want to chat mirc it always say you are not welcome on this network you have been autokilled no ident response. dragons.ca.us.dal.net- *** autokilled for [AKILL ID:1044655424K-a] [exp/identd] IRC clients from your domain are required to respond to identd requests in order to connect to DALnet. Send email to exploits@dal.net with [exp/ident] as the subject for more information. (2004/04/05 15.49) this are the message that comes up on my screen pls help me. i would appreciate any help pls. thank u
-


Re: enable identd/autokill #134 08/04/04 01:08 PM
Joined: Feb 2003
Posts: 3,432
S
sparta Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Feb 2003
Posts: 3,432
try type in your status window: /identd on som_ident


if ($me != tired) { return } | else { echo -a Get a pot of coffee now $+($me,.) }
Re: enable identd/autokill #135 09/04/04 03:57 AM
Joined: Dec 2002
Posts: 3,127
P
ParaBrat Offline OP
Hoopy frood
OP Offline
Hoopy frood
P
Joined: Dec 2002
Posts: 3,127
as the first post on this thread says, also be sure you arent blocking port 113


ParaBrat @#mIRCAide DALnet
Re: enable identd #136 22/04/04 02:07 PM
Joined: Apr 2004
Posts: 1
O
oskari Offline
Mostly harmless
Offline
Mostly harmless
O
Joined: Apr 2004
Posts: 1
I've been trying to configure my system to work with the servers requiring identd. Other servers let me in using mIRC 6.14.

My system is WINXP prof, and I am using F-Secure client (I've tried also F-S client unmounted)

I have configured WINXP's firewall according to advice found inin this thread, but identd not working.

The network I am accessing internet is an open access WLAN, which seems to use DHCP.

Is there any solution to my identd problem or is this a gateway issue??

Re: enable identd #137 23/09/04 08:08 PM
Joined: Sep 2004
Posts: 1
D
DamienH Offline
Mostly harmless
Offline
Mostly harmless
D
Joined: Sep 2004
Posts: 1
Hey when i try to enable i ident upon connecting i get this message

amsterdam2.nl.eu.undernet.org- *** Looking up your hostname
-
-amsterdam2.nl.eu.undernet.org- *** Checking Ident
-
-amsterdam2.nl.eu.undernet.org- *** Your forward and reverse DNS do not match, ignoring hostname.

Does anyone know what the problem could be??? I'm sure I have it set up right as long as it's just all in the options menu?

Page 1 of 3 1 2 3