I've been having this problem which has prevented me from connecting to any server for about 2 days now. It's like this:

[21:19] * Connecting to irc.gamesurge.net (6667)
[21:22] * [10053] Software caused connection abort
[21:22] * Disconnected

Typically it waits about 5 minutes before giving the abort message, sometimes longer and sometimes shorter. Another thing is that sometimes it alternates between this message and a simple 'Unable to connect to server (Connection timed out)'.

Before someone links me to that sticky thread, let me just say that I've read through the whole of it. I've also done hours of searching elsewhere, reading through countless descriptions and 'solutions' even though I don't fully understand a lot of this stuff frown Now I'm not a tech genius (being only a teenager), but I've tried various things to resolve this problem that were mentioned in the sticky thread and other places.

Here's what I've done:

  • I checked my Windows Firewall settings - not being blocked here.
  • I experimented with opening ports and trying different ports to connect to the server - didn't help.
  • I checked my AVG Antivirus settings (what few there are) - couldn't find any problems here either.
  • I then tried turning off AVG but still couldn't connect.
  • I ran AVG, Spybot Search & Destroy, AdAware and CrapCleaner which got rid of some regular junk, but this didn't have any effect.
  • I looked through all the Options and Settings I could find that might be related to this in some way, to no avail.
  • I downloaded VIRC, but got exactly the same error on trying to connect with this.
  • I downloaded mIRC on my mum's computer and tried connecting, and the same problem occurred.

I can connect to MSN Messenger and all my online games fine.

One thing to note is that our internet connection (BT Yahoo Broadband) has been rather slow in general lately. My mum noticed that Outlook Express was being extremely slow. However, doing a speed test showed a 'Normal' result. My signal strength is fine. It's rather confusing.

Anyway, after all these things I did a system restore going back to Saturday, way before this problem started. And it's still not working!

Our thinking is that this is a problem on the side of our internet provider (BT). Can anyone confirm this? Any help at all would be appreciated.