I had the same issue with Firefox when upgrading, changing a Firefox option is what fixed it for me:

In Firefox:
- Go to 'Tools'
- Go to 'Options'
- Click on the 'Advanced' button in the options dialog.
- Scroll down to 'Tabbed Browsing' and expand it.
- Under the title 'Open links from other applications in:' click the radio button saying 'a new window'.
- Click 'OK' and restart Firefox to make sure the setting is saved.

Does this fix your problem? smile